KEVWire

Security intelligence, with context.

Response snapshot Oct 27, 2026, 23:56 UTC

Back to the wire
Permalink
VulnerabilityCVE-2026-116687

CKEditor: Cross-site scripting (XSS) in the engine package

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine.

At a glance

Exploited
Not known
Severity
3.1 Low (CVSS 3.1)
Chance of exploitation
Not estimated
Sources
1 source

What to do

GitHub lists first patched versions: ckeditor5: 47.7.4; @ckeditor/ckeditor5-engine: 47.7.4; ckeditor5: 48.5.1; @ckeditor/ckeditor5-engine: 48.5.1. Confirm the affected range and upgrade guidance in the exact advisory.

Read GitHub-reviewed advisory GHSA-v6mg-96c6-gmpq (opens a new tab)

What happened

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.

This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.

Patches

Continue reading

The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).

For more information

Email us at [security@cksource.com](mailto:security@cksource.com) if you have any questions or comments about this advisory.

Affected package ranges reported by GitHub: ckeditor5: >= 29.0.0, < 47.7.4 @ckeditor/ckeditor5-engine: >= 29.0.0, < 47.7.4 ckeditor5: >= 48.0.0, < 48.5.1 @ckeditor/ckeditor5-engine: >= 48.0.0, < 48.5.1

Scores and how they were measured

CVSS base severity

3.1

Version 3.1As of

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Measurement source (opens a new tab)

How bad it is if exploited. Not a prediction of exploitation or proof you are exposed.

EPSS probability

Not available

A model's estimate of exploitation in the next 30 days, not certainty or your own risk.

Related technology

Sources

  1. Primary source

    GitHub-reviewed advisory GHSA-v6mg-96c6-gmpq (opens a new tab)

    The public advisory supplies the description, affected package/version ranges, and any listed CVSS metric. GitHub review is not local review.

    Published Checked

  2. Primary source

    GitHub public advisory API page (opens a new tab)

    The API page supplied GHSA-v6mg-96c6-gmpq, its actual identifiers, source dates, and structured metrics.

    Published Date not suppliedChecked

Cite this record

For factual claims, cite the primary sources above; cite KEVWire for its compilation, dates, and classifications.

APA

KEVWire. (2026, October 27). CKEditor: Cross-site scripting (XSS) in the engine package (CVE-2026-116687). https://kevwire.com/record/CVE-2026-116687

MLA

"CKEditor: Cross-site scripting (XSS) in the engine package (CVE-2026-116687)." KEVWire, 27 Oct. 2026, kevwire.com/record/CVE-2026-116687.

Chicago

KEVWire. "CKEditor: Cross-site scripting (XSS) in the engine package (CVE-2026-116687)." Last modified October 27, 2026. https://kevwire.com/record/CVE-2026-116687.

Evidence summary (plain text)

CKEditor: Cross-site scripting (XSS) in the engine package (Oct 27, 2026).
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.

This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.

The problem has been recognized and patched.
CVSS 3.1 (version 3.1; evidence as of Oct 27, 2026; https://github.com/advisories/GHSA-v6mg-96c6-gmpq).
Sources:
GitHub-reviewed advisory GHSA-v6mg-96c6-gmpq: https://github.com/advisories/GHSA-v6mg-96c6-gmpq
GitHub public advisory API page: https://api.github.com/advisories?type=reviewed&per_page=100&sort=updated&direction=desc
Record ID: CVE-2026-116687.
Record origin: Ingested record.
AI evidence: Not assessed.
Known exploitation: Not assessed.
Zero-day status: Not assessed. KEV membership alone does not establish zero-day status.
About this data

This record was ingested from a data source. Retrieved: Oct 27, 2026, 23:40 UTC. Ingestion is not an independent editorial investigation.

A CISA KEV listing documents known exploitation, not necessarily a zero-day; absence from the catalog does not prove a vulnerability has never been exploited.

Technology tags indicate possible relevance, not verified exposure. Confirm the affected product, version, and configuration against your own inventory; KEVWire does not scan your systems.

A personal reading checklist on this device, not verified remediation.

Record JSON

Your account

Email alerts

Email alerts are not available yet. To follow your stack today, use its RSS feed, which honors your filters, or connect an AI agent through the API.

Suggest an improvement

Ideas, missing sources, corrections, and bugs are all welcome. No account needed. Suggestions are reviewed by a person before anything changes.

Record details

Record detail