KEVWire

Security intelligence, with context.

Response snapshot Oct 28, 2026, 17:11 UTC

Back to the wire
Permalink
VulnerabilityCVE-2026-45048

OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC

Description An insufficient authorization (CWE-285) and information exposure (CWE-200) issue in OpenAM's session management endpoint allows a low-privileged authenticated user to retrieve active session credentials belonging to other users, including those with higher privileges.

At a glance

Exploited
Not known
Severity
8.5 High (CVSS 3.1)
Chance of exploitation
Not estimated
Sources
1 source

What to do

GitHub lists first patched versions: org.openidentityplatform.openam:openam-core: 16.1.1. Confirm the affected range and upgrade guidance in the exact advisory.

Read GitHub-reviewed advisory GHSA-vvhj-w2jq-263q (opens a new tab)

What happened

Summary

Description

An insufficient authorization (CWE-285) and information exposure (CWE-200) issue in OpenAM's session management endpoint allows a low-privileged authenticated user to retrieve active session credentials belonging to other users, including those with higher privileges. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.

This may be related to CVE-2021-4201, a similar issue patched in ForgeRock Access Management, a separate product sharing a common codebase ancestry.

Continue reading

Impact

OpenAM Community Edition deployments through version 16.0.6 using stateful session storage and exposing the session management endpoint are potentially affected. The endpoint does not enforce ownership or privilege checks when querying session information, meaning an authenticated user may retrieve active session credentials for arbitrary users.

Successful exploitation requires a valid low-privilege session and knowledge of a target user's identity identifier, which may be obtainable through normal platform functionality.

If credentials belonging to a highly privileged account are obtained, this could enable further administrative actions within the platform

Patch

This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.

Affected package ranges reported by GitHub: org.openidentityplatform.openam:openam-core: <= 16.0.6

Scores and how they were measured

CVSS base severity

8.5

Version 3.1As of

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

Measurement source (opens a new tab)

How bad it is if exploited. Not a prediction of exploitation or proof you are exposed.

EPSS probability

Not available

A model's estimate of exploitation in the next 30 days, not certainty or your own risk.

Related technology

Sources

  1. Primary source

    GitHub-reviewed advisory GHSA-vvhj-w2jq-263q (opens a new tab)

    The public advisory supplies the description, affected package/version ranges, and any listed CVSS metric. GitHub review is not local review.

    Published Checked

  2. Primary source

    GitHub public advisory API page (opens a new tab)

    The API page supplied GHSA-vvhj-w2jq-263q, its actual identifiers, source dates, and structured metrics.

    Published Date not suppliedChecked

Cite this record

For factual claims, cite the primary sources above; cite KEVWire for its compilation, dates, and classifications.

APA

KEVWire. (2026, October 28). OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC (CVE-2026-45048). https://kevwire.com/record/CVE-2026-45048

MLA

"OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC (CVE-2026-45048)." KEVWire, 28 Oct. 2026, kevwire.com/record/CVE-2026-45048.

Chicago

KEVWire. "OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC (CVE-2026-45048)." Last modified October 28, 2026. https://kevwire.com/record/CVE-2026-45048.

Evidence summary (plain text)

OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC (Jun 23, 2026).
Description

An insufficient authorization (CWE-285) and information exposure (CWE-200) issue in OpenAM's session management endpoint allows a low-privileged authenticated user to retrieve active session credentials belonging to other users, including those with higher privileges. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.

This may be related to CVE-2021-4201, a similar issue patched in ForgeRock Access Management, a separate product sharing a common codebase ancestry.
CVSS 8.5 (version 3.1; evidence as of Oct 28, 2026; https://github.com/advisories/GHSA-vvhj-w2jq-263q).
Sources:
GitHub-reviewed advisory GHSA-vvhj-w2jq-263q: https://github.com/advisories/GHSA-vvhj-w2jq-263q
GitHub public advisory API page: https://api.github.com/advisories?type=reviewed&per_page=100&sort=updated&direction=desc
Record ID: CVE-2026-45048.
Record origin: Ingested record.
AI evidence: Not assessed.
Known exploitation: Not assessed.
Zero-day status: Not assessed. KEV membership alone does not establish zero-day status.
About this data

This record was ingested from a data source. Retrieved: Oct 28, 2026, 16:55 UTC. Ingestion is not an independent editorial investigation.

A CISA KEV listing documents known exploitation, not necessarily a zero-day; absence from the catalog does not prove a vulnerability has never been exploited.

Technology tags indicate possible relevance, not verified exposure. Confirm the affected product, version, and configuration against your own inventory; KEVWire does not scan your systems.

A personal reading checklist on this device, not verified remediation.

Record JSON

Your account

Email alerts

Email alerts are coming as part of KEVWire Premium: join the waitlist. To follow your stack today, use its RSS feed, which honors your filters, or connect an AI agent through the API.

Suggest an improvement

Ideas, missing sources, corrections, and bugs are all welcome. No account needed. Suggestions are reviewed by a person before anything changes.

Record details

Record detail