KEVWire

Security intelligence, with context.

Response snapshot Nov 4, 2026, 23:06 UTC

Back to the wire
Permalink
VulnerabilityCVE-2026-49877

Apache ActiveMQ Improper Authorization vulnerability

Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.

At a glance

Exploited
Not known
Severity
8.1 High (CVSS 3.1)
Chance of exploitation
Not estimated
Sources
1 source

What to do

GitHub lists first patched versions: org.apache.activemq:apache-activemq: 5.19.8; org.apache.activemq:apache-activemq: 6.2.7. Confirm the affected range and upgrade guidance in the exact advisory.

Read GitHub-reviewed advisory GHSA-f892-4h9f-j7g9 (opens a new tab)

What happened

Improper Authorization vulnerability in Apache ActiveMQ.

An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Affected package ranges reported by GitHub: org.apache.activemq:apache-activemq: < 5.19.8 org.apache.activemq:apache-activemq: >= 6.0.0, < 6.2.7

Scores and how they were measured

CVSS base severity

8.1

Version 3.1As of

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Measurement source (opens a new tab)

How bad it is if exploited. Not a prediction of exploitation or proof you are exposed.

EPSS probability

Not available

A model's estimate of exploitation in the next 30 days, not certainty or your own risk.

Related technology

Sources

  1. Primary source

    GitHub-reviewed advisory GHSA-f892-4h9f-j7g9 (opens a new tab)

    The public advisory supplies the description, affected package/version ranges, and any listed CVSS metric. GitHub review is not local review.

    Published Checked

  2. Primary source

    GitHub public advisory API page (opens a new tab)

    The API page supplied GHSA-f892-4h9f-j7g9, its actual identifiers, source dates, and structured metrics.

    Published Date not suppliedChecked

Cite this record

For factual claims, cite the primary sources above; cite KEVWire for its compilation, dates, and classifications.

APA

KEVWire. (2026, November 4). Apache ActiveMQ Improper Authorization vulnerability (CVE-2026-49877). https://kevwire.com/record/CVE-2026-49877

MLA

"Apache ActiveMQ Improper Authorization vulnerability (CVE-2026-49877)." KEVWire, 4 Nov. 2026, kevwire.com/record/CVE-2026-49877.

Chicago

KEVWire. "Apache ActiveMQ Improper Authorization vulnerability (CVE-2026-49877)." Last modified November 4, 2026. https://kevwire.com/record/CVE-2026-49877.

Evidence summary (plain text)

Apache ActiveMQ Improper Authorization vulnerability (Jun 30, 2026).
Improper Authorization vulnerability in Apache ActiveMQ.

An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins.
This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
CVSS 8.1 (version 3.1; evidence as of Nov 4, 2026; https://github.com/advisories/GHSA-f892-4h9f-j7g9).
Sources:
GitHub-reviewed advisory GHSA-f892-4h9f-j7g9: https://github.com/advisories/GHSA-f892-4h9f-j7g9
GitHub public advisory API page: https://api.github.com/advisories?type=reviewed&per_page=100&sort=updated&direction=desc
Record ID: CVE-2026-49877.
Record origin: Ingested record.
AI evidence: Not assessed.
Known exploitation: Not assessed.
Zero-day status: Not assessed. KEV membership alone does not establish zero-day status.
About this data

This record was ingested from a data source. Retrieved: Nov 4, 2026, 23:05 UTC. Ingestion is not an independent editorial investigation.

A CISA KEV listing documents known exploitation, not necessarily a zero-day; absence from the catalog does not prove a vulnerability has never been exploited.

Technology tags indicate possible relevance, not verified exposure. Confirm the affected product, version, and configuration against your own inventory; KEVWire does not scan your systems.

A personal reading checklist on this device, not verified remediation.

Record JSON

Your account

Email alerts

Email alerts are coming as part of KEVWire Premium: join the waitlist. To follow your stack today, use its RSS feed, which honors your filters, or connect an AI agent through the API.

Suggest an improvement

Ideas, missing sources, corrections, and bugs are all welcome. No account needed. Suggestions are reviewed by a person before anything changes.

Record details

Record detail