KEVWire

Security intelligence, with context.

Response snapshot Nov 4, 2026, 23:06 UTC

Back to the wire
Permalink
VulnerabilityCVE-2026-55955

Apache Tomcat has an Improper Authentication vulnerability

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.118, from 8.5.38 through 8.5.

At a glance

Exploited
Not known
Severity
6.5 Medium (CVSS 3.1)
Chance of exploitation
Not estimated
Sources
1 source

What to do

GitHub lists first patched versions: org.apache.tomcat:tomcat: 11.0.23; org.apache.tomcat:tomcat: 10.1.56; org.apache.tomcat:tomcat: 9.0.119; org.apache.tomcat:tomcat-tribes: 11.0.23; org.apache.tomcat:tomcat-tribes: 10.1.56; org.apache.tomcat:tomcat-tribes: 9.0.119. Confirm the affected range and upgrade guidance in the exact advisory.

Read GitHub-reviewed advisory GHSA-c5ph-rghf-fjfj (opens a new tab)

What happened

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.118, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.

Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.

Affected package ranges reported by GitHub: org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.23 org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.56 org.apache.tomcat:tomcat: >= 9.0.13, < 9.0.119 org.apache.tomcat:tomcat: >= 8.5.38, <= 8.5.100 org.apache.tomcat:tomcat: >= 7.0.100, <= 7.0.109 org.apache.tomcat:tomcat-tribes: >= 11.0.0-M1, < 11.0.23 org.apache.tomcat:tomcat-tribes: >= 10.1.0-M1, < 10.1.56 org.apache.

Continue reading

tomcat:tomcat-tribes: >= 9.0.13, < 9.0.119 org.apache.tomcat:tomcat-tribes: >= 8.5.38, <= 8.5.100 org.apache.tomcat:tomcat-tribes: >= 7.0.100, <= 7.0.109

Scores and how they were measured

CVSS base severity

6.5

Version 3.1As of

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Measurement source (opens a new tab)

How bad it is if exploited. Not a prediction of exploitation or proof you are exposed.

EPSS probability

Not available

A model's estimate of exploitation in the next 30 days, not certainty or your own risk.

Related technology

Sources

  1. Primary source

    GitHub-reviewed advisory GHSA-c5ph-rghf-fjfj (opens a new tab)

    The public advisory supplies the description, affected package/version ranges, and any listed CVSS metric. GitHub review is not local review.

    Published Checked

  2. Primary source

    GitHub public advisory API page (opens a new tab)

    The API page supplied GHSA-c5ph-rghf-fjfj, its actual identifiers, source dates, and structured metrics.

    Published Date not suppliedChecked

Cite this record

For factual claims, cite the primary sources above; cite KEVWire for its compilation, dates, and classifications.

APA

KEVWire. (2026, November 4). Apache Tomcat has an Improper Authentication vulnerability (CVE-2026-55955). https://kevwire.com/record/CVE-2026-55955

MLA

"Apache Tomcat has an Improper Authentication vulnerability (CVE-2026-55955)." KEVWire, 4 Nov. 2026, kevwire.com/record/CVE-2026-55955.

Chicago

KEVWire. "Apache Tomcat has an Improper Authentication vulnerability (CVE-2026-55955)." Last modified November 4, 2026. https://kevwire.com/record/CVE-2026-55955.

Evidence summary (plain text)

Apache Tomcat has an Improper Authentication vulnerability (Jun 29, 2026).
Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.118, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.

Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
CVSS 6.5 (version 3.1; evidence as of Nov 4, 2026; https://github.com/advisories/GHSA-c5ph-rghf-fjfj).
Sources:
GitHub-reviewed advisory GHSA-c5ph-rghf-fjfj: https://github.com/advisories/GHSA-c5ph-rghf-fjfj
GitHub public advisory API page: https://api.github.com/advisories?type=reviewed&per_page=100&sort=updated&direction=desc
Record ID: CVE-2026-55955.
Record origin: Ingested record.
AI evidence: Not assessed.
Known exploitation: Not assessed.
Zero-day status: Not assessed. KEV membership alone does not establish zero-day status.
About this data

This record was ingested from a data source. Retrieved: Nov 4, 2026, 23:05 UTC. Ingestion is not an independent editorial investigation.

A CISA KEV listing documents known exploitation, not necessarily a zero-day; absence from the catalog does not prove a vulnerability has never been exploited.

Technology tags indicate possible relevance, not verified exposure. Confirm the affected product, version, and configuration against your own inventory; KEVWire does not scan your systems.

A personal reading checklist on this device, not verified remediation.

Record JSON

Your account

Email alerts

Email alerts are coming as part of KEVWire Premium: join the waitlist. To follow your stack today, use its RSS feed, which honors your filters, or connect an AI agent through the API.

Suggest an improvement

Ideas, missing sources, corrections, and bugs are all welcome. No account needed. Suggestions are reviewed by a person before anything changes.

Record details

Record detail